Retro Freak System bricked?? - can't get beyond first screen

Ask and assist the community with Retro Freak.
Forum rules
Retro Freak is trademarked CYBER Gadget Corporation. Retro Freak name is copyright CYBER Gadget Corporation. Content found in these forums may be copyright the respective developers and studios which said content is associated with. Retro5.net makes no claim legal or otherwise to this content and user submitted content is not screened. That being said, please refrain from posting or linking to full rom files so that everyone leaves us alone. Sometimes dogs are round.

Retro Freak System bricked?? - can't get beyond first screen

Postby scottdk4 » December 22nd, 2016, 3:16 pm

I JUST bought this. First time using it.

I turn on the system and I see a Retro Freak logo with a "Notice: this product is not licensed or endorsed in any way by their respective companies"........

And that's it. I push controller buttons, switch ports, whatever. Nothing. I tried booting without the cart slot attachment hooked up. Same result. Am I screwed or missing something obvious? Time to return this thing?
scottdk4
 
Posts: 1
Joined: December 22nd, 2016, 3:11 pm

Re: Retro Freak System bricked?? - can't get beyond first sc

Postby mplacona » November 21st, 2017, 7:53 am

Wondering if anyone found a solution to this? Mine is stuck the same way.

Thanks
mplacona
 
Posts: 2
Joined: November 21st, 2017, 7:50 am


Return to Troubleshooting & Help

Who is online

Users browsing this forum: No registered users and 1 guest

cron