Page 1 of 1

Game Gear - Castle of Illusion

PostPosted: December 9th, 2016, 6:08 am
by chris
Hi there!
I've dumped my Castle of Illusion (EU) Game Gear now several times - Retro Freak identifies the game correctly and reports no errors but when starting the game it is not working correctly (sound is OK but colors and screens are completely messed up).
Anyone else has this problem? I'm not sure if this is a problem with my cart, with the dumping process or with the emulation.

Re: Game Gear - Castle of Illusion

PostPosted: December 9th, 2016, 11:25 pm
by R9delta
If the game is identified correctly then the cartridge itself is fine. The Retron 5 and Retro Freak identify a game by it's CRC (identification of it's data after read and dumped byte for byte) so if there was any issue on that end it would have read as an unidentified title. It's the emulation that's the problem that you speak of...and therefore only something hyperkin can do to fix.

Re: Game Gear - Castle of Illusion

PostPosted: December 13th, 2016, 12:27 pm
by chris
Thanks for your answer. I did some research and seems the GG cart is basically the same as the SMS cart with just an adapter inside the cart (http://www.smspower.org/forums/6585-Pro ... orGameGear).

I renamed the dumped file to .SMS to see what happens - and it actually works perfectly fine as a Master System game.

The conclusion is just as you said - the dump was correct, but it seems to be an emulator issue. :-)

Re: Game Gear - Castle of Illusion

PostPosted: December 13th, 2016, 4:44 pm
by R9delta
Well I'm glad you had gotten it at least working as an SMS game. I honestly missed that fact when I first read your post, this has actually been a known issue with that particular game and emulators for a long time..in addition that you were referring to the Retro Freak and not the R5 (which is fine since functionally they are the same when it comes to these matters minus rom playing capability without work arounds)