Page 1 of 2

Nvidia Shield TV

PostPosted: July 19th, 2016, 3:02 am
by Lilith
I finally got my Shield set up after a few hours of trying to get the apks installed, was running into a parse error...but I ended up digging into the actual SD directory and installing them that way.

Anyway, I'm still hunting for games for my various emulators, but I tried Retro Arch earlier, and at first it crashed when I went back to the Shield menu, then it froze while downloading a GBA emulator core (I know how to work it, I got everything working on PC a few days ago)

I'd much rather have all my games in one place (as much as possible), so I really don't want to have to resort to PC Retro Arch...but if it's going to be crashing on me, I might as well. Am I doing something wrong? Is it possible I got a bad APK?

I have a couple questions as well. How do I move around the menu in a lot of these emulators? I noticed in the GBC one, there was a mouse, but I've tried everything I can think of in the N64 emu and can't seem to do anything.

Also, I assume for Saturn ISOs I need to do that numbering thing with the ISOs and MP3s and stick them in the same folder to get music (like I've done with Sega CD on PSP)

I can't seem to move just one space on the Saturn emu menu, and it's very irritating. Is there a way to fix that?

Re: Nvidia Shield TV

PostPosted: July 19th, 2016, 10:01 am
by R9delta
You might have just got a bad APK. Redownload the newest stable version from libretro's website (which is 1.3.6)

Here are the cores I use personally if it's any help:

NES - Fceu
SNES - SNES9x-Next
Gameboy/Color - Gambette
Genesis - Both GenesisPlus and Pico (One of them is needed for Game Gear games that the other doesn't, one is 32x. Otherwise both cover most)
Playstation - PCSX-ReARMed
Atari 2600 - Stella
Atari 7800 - Pro System
Arcade - FBA (works better for CPS1, CPS2, and Neo Geo Games), MAME (other games here or there)
PC Engine - Mednafen SGX (will cover SuperGrafX games and PC Engine/Turbo Grafx, not neccesary to get other Mednafen unless you want to run PC Engine CD games, then get both cores)
N64 - Mupen64Plus (few tips, change cpu to dynamic recompilation and resolution to 320x240 for speed up which will tend to allow full speed in most games..keep in mind n64 games typically ran at awful framerate to begin with)
WonderSwan, Neo Geo Pocket - I don't remember the names of the cores but they're the only available ones for those handhelds, they work great

Preferred Shader configuration - I prefer CRT-Easymode-Halation under the CRT folder. Looks great. I also turn off bilinear filtering in the video options.

Basic folder layout - For my sanity and better organization, I have a separate folder called "Emulation", under those i have three folders...Roms (with folders for that for each system), BIOS, and Saves. I configure RetroArch to look for Roms, BIOS files, and Saves/Savestates under those directories. They're on my hard drive since i've got the 500GB. Might be good to stick them on your MicroSD card if you've got a 16gb or do that anyway even if you had the 500gb. Makes it easier to manage them outside the Shield.

The reason I pick some of these cores that I do is for usually 3 reasons...overall compatibility, speed, and familiarity. Some of these cores the Retro Freak and Retron 5 actually use and I've never had a huge issue with them...sometimes its that the alternative cores are too slow or not as developed.

Some notes, Saturn core, PSP core, and Nintendo DS core are way too slow in RetroArch. I enjoy playing these systems and prefer to keep all my emulators in one place but if you're going to play these games use the apps Drastic (paid but worth every penny of that 5.99, plays DS games perfect and can upscale them in HD), uoYaubeuse for Saturn games (few games work great but some not so much, kinda get mixed results. I've had some trouble getting some ISOs to appear despite knowing what i'm doing), and PPSSPP. Lot of PSP games run perfect, a mix do not.

As far as the CD based systems go, my biggest preference is that the ISOs are in .bin/.cue format (as well as games that contain CD/Redbook audio having their tracks in .bin format too). Generally I luck out in most of the games I download. They tend to already be in that format though I usually have to do some renaming of the files and editing of their cue files to match. I download off of when I can. I find because CD based games can be in a million different ISO formats I tend to avoid them though unless it's a game I really want to play and it's worth the trouble for me to make it work.

As far as RetroArch crashing, it does crash for me if i get out of RetroArch through the home button instead of properly exiting and i play with another app. It doesn't seem to play well with multi-tasking on the Shield. Best just to deal with it or exit RetroArch properly when getting out of it. Never had it crash on me otherwise unless i was playing with other cores that were troublesome.

Re: Nvidia Shield TV

PostPosted: July 19th, 2016, 5:30 pm
by Lilith
Thanks as always for all the advice. I've been messing with Retro Arch on the Shield, but I get no sound in games. Is this some sort of driver issue? Also, is there a way to make the touch screen overlay go away?

Re: Nvidia Shield TV

PostPosted: July 19th, 2016, 10:35 pm
by R9delta
Not sure about the sound issue you're having...its worked gear for me. As for the controller overlay, yeah it can be disabled. Its in overlay settings

Re: Nvidia Shield TV

PostPosted: July 19th, 2016, 11:33 pm
by Lilith
I guess the Shield was still set to auto detect volume or something, I changed it to fixed output and the sound now works fine. I don't know if I got a remote with it that would have made it easier.

Also, how do I load CD games on Retro Arch? I download the cores that support em (Sega CD/TGCD), but none of those games show up under those cores, just cart games.

Re: Nvidia Shield TV

PostPosted: July 19th, 2016, 11:37 pm
by R9delta
I don't know about TGCD but for Sega CD you need the BIOS files if you don't already have them. This page:

...will tell you what they need to be named when you find them. Put them in the designated bios directory. I'm not sure if that's why CD games are not showing up for you but its possible and this is just to make sure you've covered that ground.

Re: Nvidia Shield TV

PostPosted: July 20th, 2016, 12:05 am
by Lilith
Hm....I tried to put them in the Android folder, the SCD/PCE folder, the base RetroArch folder (Android>RetroArch), and the files folder. Nothing worked.

Re: Nvidia Shield TV

PostPosted: July 20th, 2016, 12:34 am
by R9delta
Lilith wrote:Hm....I tried to put them in the Android folder, the SCD/PCE folder, the base RetroArch folder (Android>RetroArch), and the files folder. Nothing worked.

Make a BIOS folder yourself, put them in there and go to the directory settings under RetroArch and set it to point to the folder you made.

Re: Nvidia Shield TV

PostPosted: July 20th, 2016, 12:55 am
by Lilith
Hmmmm...I set up the BIOS directory to a folder where I put the Sega CD, Saturn, FDS, and PCE CD BIOs, but it still doesn't seem to want to recognize the games, even when I rescan and update the database.

Also, when I try to start the Saturn emulator you listed (Yaubuse standalone), I get "cannot initialize iso file virtual drive". From what I can tell, that's an error people usually get when trying to load certain ISOs, but I get it before even getting into the program

Do I need PS1 BIOs to play PS1 games, even though they show up without them?

Re: Nvidia Shield TV

PostPosted: July 25th, 2016, 2:59 am
by Lilith
I've figured everything else out (PCE still don't show up, but they work when I load them), PS1 works, I haven't tried FDS, Sega CD...doesn't work, Lunar 1 and Vay crash Retro Arch.

Do you have an N64 controller layout you use? Will Retro Arch detect USB controllers? I do have an N64>USB adapter that seems useful since N64 has such a weird controller.

I'd still love to get Yaubuse working (RA's Saturn core is a bit choppy).

I've gotten around to setting directory shortcuts and the like, but I started to try to put Retro Arch on my old Shield Portable, but when I tried to download cores, it said "task failed". I took the SD card and put it back in my Shield TV, same thing now. I'm hoping this is just a bug with Retro Arch.